Melbourne IT Shopping Cart Issues
Incident Report for Melbourne IT Service Status
Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 15:40 AEDT
Investigating
We would like to advise that we are currently experiencing technical difficulties with our Melbourne IT Website Shopping Cart, which is affecting new customer's ability to search and buy domains. Existing customers are not affected and can order through their accounts.

We are currently investigating the issue and working to resolve this urgently.
Posted Mar 02, 2021 - 14:51 AEDT
This incident affected: Melbourne IT Infrastructure (Shopping Cart).