Phone System and Live Chat Service Disruption
Incident Report for Melbourne IT Service Status
Resolved
We have been monitoring this incident for the last 24 hours and can confirm that this has been resolved.
Posted Sep 30, 2020 - 13:00 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2020 - 10:25 AEST
Identified
Due to a critical outage at Microsoft, our phone, live chat and ticket system are not available at present.
As soon as the incident is fixed we will be available to help you. In the interim, please log a ticket through your account or on our website and we will get to it as soon as possible.
Posted Sep 29, 2020 - 08:28 AEST
This incident affected: Support Centre (Live Chat, Phone Sales/Support Line, Web/Email Support Enquires).