Customer Service Incident
Incident Report for Melbourne IT Service Status
Resolved
We would like to inform our customers that this incident has now been resolved.

Customers are now able to contact us via all Customer Service Platforms including Live chat, email and phone.

We apologise for any inconvenience this may have caused.
Posted May 12, 2022 - 11:35 AEST
Investigating
We would like to inform our customers of a current issue impacted by an external provider, affecting our ability to serve our customers.

Customers are currently unable to contact our Service Teams via Live chat and email.

We will be providing an update on this incident at 12.00pm AEST and appreciate your patience
Posted May 12, 2022 - 11:12 AEST
This incident affected: Support Centre (Live Chat, Email Support, Domainz Support).