Melbourne IT - Phone Support Interruption
Resolved
Feb 2, 2017 05:31 AEDT
Incident Updates
-
Resolved Feb 2, 2017 23:31 AEDT
Phone systems have been restored and no further issues have been identified since yesterday. Apologies for any inconvenience this may have caused.
-
Resolved Feb 2, 2017 05:31 AEDT
We wish to advise our customers we are currently experiencing technical difficulties with our phone support system. Our platform engineers are currently investigating this as a high priority. Customers requiring support can still use our live chat and email services to contact us. Thank you for your patience while we address this interruption