Melbourne IT
← Back to status

Phone/Live Chat Service Interruption

Resolved Jul 12, 2017 07:20 AEST

Incident Updates

  • Resolved Jul 12, 2017 07:46 AEST

    The issue with our phone and live chat systems have been restored. We thank you for your patience during this period.

  • Resolved Jul 12, 2017 07:20 AEST

    We wish to advise our customers that we are currently experiencing technical difficulties with our phone and live chat systems. Our platform engineers are currently investigating this as a high priority. We recommend customers requiring support use our email channels. Thank you for your patience while we address this interruption.