Melbourne IT
← Back to status

Service Disruption - Phone System

Resolved Apr 11, 2018 22:04 AEST

Incident Updates

  • Resolved Apr 12, 2018 00:33 AEST

    Phone systems have started functioning as per normal and agents are now available through our phone lines. Apologies for any inconvenience this may have caused.

  • Resolved Apr 11, 2018 22:04 AEST

    We are currently experiencing issues with our phone systems. Technicians are looking into this as a priority. Live Chat and Email support are unaffected by this issue, although wait times may be longer than usual. We apologize for the inconvenience this incident may cause you