Melbourne IT
← Back to status

Cloud webmail disruption

Resolved Apr 11, 2019 23:54 AEST

Incident Updates

  • Resolved Apr 12, 2019 04:19 AEST

    This incident has been resolved.

  • Resolved Apr 12, 2019 03:37 AEST

    A fix has been implemented and we are monitoring the results.

  • Resolved Apr 11, 2019 23:54 AEST

    We are currently investigating an issue affecting customers with cloud email services, whereby they are unable to access webmail. This issue is being investigated as a priority and updates will be posted as they are available. We appreciate your patience.