Melbourne IT
← Back to status

Cloud Email Issues

Resolved May 14, 2020 05:15 AEST

Incident Updates

  • Resolved May 20, 2020 22:39 AEST

    We would like to confirm that the Cloud Emails and Anti-spam services are now operating effectively. Thank you for your patience and understanding during this time.

  • Resolved May 19, 2020 04:37 AEST

    Thank you for your patience with us while resolving the on-going SpamExpert email issues. Customers that have experienced the inability to receive emails while using our Cloud Email and Anti-spam services will notice that these issues have been resolved. Our System Administrators will continue to monitor this to confirm that the Cloud Emails and Anti-spam services are operating effectively. If you are still affected by these problems, let our Support Representatives know via our LiveChat or Email Support options.

  • Resolved May 14, 2020 05:29 AEST

    We'd like to inform Customers on our Cloud email environment of on-going email issues. Customers using our SpamExpert (email filtering) service had experienced a temporary inability to receive emails. Our Melbourne IT technicians have made changes so that emails are now being received, however, customers will notice a higher number of spam emails being received. Thank you for your patience and understanding, we will continue to update our customers on this through the resolution process.

  • Resolved May 14, 2020 05:15 AEST

    We'd like to inform Customers on our Cloud email environment of on-going email issues. Customers using our SpamExpert (email filtering) service are unable to receive emails. Our Melbourne IT technicians are currently looking into this with a matter of urgency. Thank you for your patience and understanding, we will continue to update our customers on this through the resolution process.