Phone System Service Disruption
Resolved
Jul 20, 2020 10:45 AEST
Incident Updates
-
Resolved Jul 21, 2020 02:56 AEST
This incident has been resolved.
-
Resolved Jul 20, 2020 11:29 AEST
A fix has been implemented and we are monitoring the results.
-
Resolved Jul 20, 2020 10:45 AEST
We are currently experiencing issues with our phone system. Our technicians are looking into this as a priority. Live chat and email support are unaffected by this issue, although wait times may be longer than usual. We apologise for any inconvenience this incident may cause you.