Melbourne IT
← Back to status

Delays in ticket and account notifications

Resolved Jun 21, 2025 00:33 AEST

Incident Updates

  • Resolved Jun 23, 2025 01:22 AEST

    This was resolved at 2.30am GMT. Thank you for your patience.

  • Resolved Jun 21, 2025 00:33 AEST

    We're currently experiencing some delays in sending notifications regarding customer support responses and other account-related updates. Our team is actively investigating the issue, and we appreciate your patience in the meantime.